re = /([+-]?(?:'.+?'|".+?"|[^+\- ]{1}[^ ]*))/
str = 'something else +good -bad \'other stuff\' ++\'good stuff\' -"bad stuff" ---"dall\'orto" a v ac'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end