using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([+-]?(?:'.+?'|"".+?""|[^+\- ]{1}[^ ]*))";
string input = @"something else +good -bad 'other stuff' ++'good stuff' -""bad stuff"" ---""dall'orto"" a v ac";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}