$re = '/([+-]?(?:\'.+?\'|".+?"|[^+\- ]{1}[^ ]*))/';
$str = 'something else +good -bad \'other stuff\' ++\'good stuff\' -"bad stuff" ---"dall\'orto" a v ac';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);