$re = '/(<script.*>|<\/script>)/i';
$str = '<script type="text/javascript">
$("#apis-title").keyup(function () {
var nameText = $(this).val().replace(/([^a-zA-Z0-9_])/g, \'_\');
$("#apis-name").val(nameText.toLowerCase());
});
</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);