const regex = /(<script.*>|<\/script>)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<script.*>|<\\\/script>)', 'ig')
const str = `<script type="text/javascript">
\$("#apis-title").keyup(function () {
var nameText = \$(this).val().replace(/([^a-zA-Z0-9_])/g, '_');
\$("#apis-name").val(nameText.toLowerCase());
});
</script>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}