package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(<script.*>|<\/script>)`)
var str = `<script type="text/javascript">
$("#apis-title").keyup(function () {
var nameText = $(this).val().replace(/([^a-zA-Z0-9_])/g, '_');
$("#apis-name").val(nameText.toLowerCase());
});
</script>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}