$re = '/throw new UserException\(\'(.*)\'\)/';
$str = 'throw new UserException(\'test\');
throw new UserException(\'require\');
throw new UserException(\'working\');
throw new UserException(\'okay\');
throw new UserException(\'regular\');
throw new UserException(\'works!\');';
$subst = "throw new UserException(\"$1\");";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;