using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"throw new UserException\('(.*)'\)";
string substitution = @"throw new UserException(""$1"");";
string input = @"throw new UserException('test');
throw new UserException('require');
throw new UserException('working');
throw new UserException('okay');
throw new UserException('regular');
throw new UserException('works!');";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}