package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`throw new UserException\('(.*)'\)`)
var str = `throw new UserException('test');
throw new UserException('require');
throw new UserException('working');
throw new UserException('okay');
throw new UserException('regular');
throw new UserException('works!');`
var substitution = "throw new UserException("$1");"
fmt.Println(re.ReplaceAllString(str, substitution))
}