// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https?:\/\/quizlet.com\/(.*\/)").unwrap();
let string = "https://quizlet.com/pl/641422382/kapitel-1-welltour-deutsch-2-flash-cards/
https://quizlet.com/pl/641422382/kapitel-1-welltour-deutsch-2-flash-cards/
https://quizlet.com/pl/626712343/focus-4-unit-5-flash-cards/
https://quizlet.com/598598503/focus-4-unit-5-flash-cards/
http://quizlet.com/pl/626712343/focus-4-unit-5-flash-cards/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}