use strict;
my $str = 'https://quizlet.com/pl/641422382/kapitel-1-welltour-deutsch-2-flash-cards/
https://quizlet.com/pl/641422382/kapitel-1-welltour-deutsch-2-flash-cards/
https://quizlet.com/pl/626712343/focus-4-unit-5-flash-cards/
https://quizlet.com/598598503/focus-4-unit-5-flash-cards/
http://quizlet.com/pl/626712343/focus-4-unit-5-flash-cards/';
my $regex = qr/^https?:\/\/quizlet.com\/(.*\/)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}