const regex = /^https?:\/\/quizlet.com\/(.*\/)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/quizlet.com\\\/(.*\\\/)', 'gm')
const str = `https://quizlet.com/pl/641422382/kapitel-1-welltour-deutsch-2-flash-cards/
https://quizlet.com/pl/641422382/kapitel-1-welltour-deutsch-2-flash-cards/
https://quizlet.com/pl/626712343/focus-4-unit-5-flash-cards/
https://quizlet.com/598598503/focus-4-unit-5-flash-cards/
http://quizlet.com/pl/626712343/focus-4-unit-5-flash-cards/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}