re = /[+-]?[0-9]{1,3}(?:,?[0-9]{3})*\.[0-9]{2}/
str = '0000000000.00 000,000,000,000,000.00 0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end