using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[+-]?[0-9]{1,3}(?:,?[0-9]{3})*\.[0-9]{2}";
string input = @"0000000000.00 000,000,000,000,000.00 0";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}