$re = '%[+-]?[0-9]{1,3}(?:,?[0-9]{3})*\.[0-9]{2}%';
$str = '0000000000.00 000,000,000,000,000.00 0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);