re = /\b(?-i)(?!vacation\b)\b(?i)(PTO|paid time off|time off|holiday|vacation)\b/m
str = 'I want to take 5 days pto
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end