const regex = /\b(?-i)(?!vacation\b)\b(?i)(PTO|paid time off|time off|holiday|vacation)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?-i)(?!vacation\\b)\\b(?i)(PTO|paid time off|time off|holiday|vacation)\\b', 'gm')
const str = `I want to take 5 days pto
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}