$re = '/\b(?-i)(?!vacation\b)\b(?i)(PTO|paid time off|time off|holiday|vacation)\b/m';
$str = 'I want to take 5 days pto
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);