// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)(var )?(\"[^\"\r\n\t]+\"|[a-z0-9\_]+)\s?\:\s([a-z\[\]0-9]+)\s?(\'[^\'\;]+\'|\"[^\"\;]+\"|of [^\"\;]+|[^\"\s\;]+|)( temporary)?(?:\;|\))"#).unwrap();
let string = "local procedure OnBeforeGetNoSeriesCode(var SalesHeader: Record \"Sales Header\"; SalesSetup: Record \"Sales & Receivables Setup\"; var NoSeriesCode: Code[20]; var IsHandled: Boolean)
local procedure OnBeforeInitRecord(var SalesHeader: Record \"Sales Header\"; var IsHandled: Boolean; xSalesHeader: Record \"Sales Header\")
local procedure OnBeforeIsCreditDocType(SalesHeader: Record \"Sales Header\"; var CreditDocType: Boolean)
procedure RecreateSalesLines(ChangedFieldName: Text[100])
local procedure GetSalesSetup()
procedure PopulateItemAttributeValueSelection(var TempItemAttributeValue: Record \"Item Attribute Value\" temporary;var TestBool: Boolean)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}