const regex = /(var )?(\"[^\"\r\n\t]+\"|[a-z0-9\_]+)\s?\:\s([a-z\[\]0-9]+)\s?(\'[^\'\;]+\'|\"[^\"\;]+\"|of [^\"\;]+|[^\"\s\;]+|)( temporary)?(?:\;|\))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(var )?(\\"[^\\"\\r\\n\\t]+\\"|[a-z0-9\\_]+)\\s?\\:\\s([a-z\\[\\]0-9]+)\\s?(\\\'[^\\\'\\;]+\\\'|\\"[^\\"\\;]+\\"|of [^\\"\\;]+|[^\\"\\s\\;]+|)( temporary)?(?:\\;|\\))', 'gmi')
const str = `local procedure OnBeforeGetNoSeriesCode(var SalesHeader: Record "Sales Header"; SalesSetup: Record "Sales & Receivables Setup"; var NoSeriesCode: Code[20]; var IsHandled: Boolean)
local procedure OnBeforeInitRecord(var SalesHeader: Record "Sales Header"; var IsHandled: Boolean; xSalesHeader: Record "Sales Header")
local procedure OnBeforeIsCreditDocType(SalesHeader: Record "Sales Header"; var CreditDocType: Boolean)
procedure RecreateSalesLines(ChangedFieldName: Text[100])
local procedure GetSalesSetup()
procedure PopulateItemAttributeValueSelection(var TempItemAttributeValue: Record "Item Attribute Value" temporary;var TestBool: Boolean)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}