import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(var )?(\\\"[^\\\"\\r\\n\\t]+\\\"|[a-z0-9\\_]+)\\s?\\:\\s([a-z\\[\\]0-9]+)\\s?(\\'[^\\'\\;]+\\'|\\\"[^\\\"\\;]+\\\"|of [^\\\"\\;]+|[^\\\"\\s\\;]+|)( temporary)?(?:\\;|\\))";
final String string = "local procedure OnBeforeGetNoSeriesCode(var SalesHeader: Record \"Sales Header\"; SalesSetup: Record \"Sales & Receivables Setup\"; var NoSeriesCode: Code[20]; var IsHandled: Boolean)\n\n"
+ "local procedure OnBeforeInitRecord(var SalesHeader: Record \"Sales Header\"; var IsHandled: Boolean; xSalesHeader: Record \"Sales Header\")\n\n"
+ "local procedure OnBeforeIsCreditDocType(SalesHeader: Record \"Sales Header\"; var CreditDocType: Boolean)\n\n"
+ "procedure RecreateSalesLines(ChangedFieldName: Text[100])\n\n"
+ "local procedure GetSalesSetup()\n\n"
+ " procedure PopulateItemAttributeValueSelection(var TempItemAttributeValue: Record \"Item Attribute Value\" temporary;var TestBool: Boolean)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}