// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<.[^>]*>(\s+|()|( )*|\s+( )*|( )*\s+|\s+( )*\s+)<\/.[^>]*>").unwrap();
let string = "<p></p>
<p> </p>
<b>
</b>
<B></B>
<i> </i>
<i> </i>
<i> </i>
<strong></strong>
<i style=\"color: orange\"></i>
<a href=\"#\"> </a>
<o: class=\"ms-crap\"></o>
<p>Not empty</p>
<p>Not
empty</p>
<i>
</i>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}