package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<.[^>]*>(\s+|()|( )*|\s+( )*|( )*\s+|\s+( )*\s+)<\/.[^>]*>`)
var str = `<p></p>
<p> </p>
<b>
</b>
<B></B>
<i> </i>
<i> </i>
<i> </i>
<strong></strong>
<i style="color: orange"></i>
<a href="#"> </a>
<o: class="ms-crap"></o>
<p>Not empty</p>
<p>Not
empty</p>
<i>
</i>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}