const regex = /<.[^>]*>(\s+|()|( )*|\s+( )*|( )*\s+|\s+( )*\s+)<\/.[^>]*>/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<.[^>]*>(\\s+|()|( )*|\\s+( )*|( )*\\s+|\\s+( )*\\s+)<\\\/.[^>]*>', 'ig')
const str = `<p></p>
<p> </p>
<b>
</b>
<B></B>
<i> </i>
<i> </i>
<i> </i>
<strong></strong>
<i style="color: orange"></i>
<a href="#"> </a>
<o: class="ms-crap"></o>
<p>Not empty</p>
<p>Not
empty</p>
<i>
</i>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}