$re = '/(?i)((\d+)(x)(\d+)(\s*)(,*)(\s*))*/';
$str = '320x50, 300x250,1000X50 500x30';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);