using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)((\d+)(x)(\d+)(\s*)(,*)(\s*))*";
string input = @"320x50, 300x250,1000X50 500x30";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}