package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((\d+)(x)(\d+)(\s*)(,*)(\s*))*`)
var str = `320x50, 300x250,1000X50 500x30`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}