const regex = /(segev)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(segev)', '')
const str = `https://www.load61_242.0.Context/segev/2/a7/8a/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}