re = /<(.*|\n)*?>/
str = '<b>negrito<b>negrito interno</b>externo</b> aqui <b>negrito</b>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end