$re = '/<(.*|\n)*?>/';
$str = '<b>negrito<b>negrito interno</b>externo</b> aqui <b>negrito</b>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);