package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<(.*|\n)*?>`)
var str = `<b>negrito<b>negrito interno</b>externo</b> aqui <b>negrito</b>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}