import Foundation
let pattern = #":06..0201213(5[C-F]|[6-9A-C].|D[0-3])."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
:06800201212E39
:06800201212E40
:06800201212EA5
:06800201212F00
:06800201212FFF
:06800201213000
:068002012134FF
:06800201213500
:0680020121359F
:068002012135A1
:068002012135BF
:068002012135C0
:068002012136A1
:06800201213A01
:06800201213CFF
:06800201213D01
:06800201213D3F
:06800201213D40
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)