# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r":06..0201213(5[C-F]|[6-9A-C].|D[0-3])."
test_str = (":06800201212E39\n"
":06800201212E40\n"
":06800201212EA5\n"
":06800201212F00\n"
":06800201212FFF\n"
":06800201213000\n"
":068002012134FF\n"
":06800201213500\n"
":0680020121359F\n"
":068002012135A1\n"
":068002012135BF\n"
":068002012135C0\n"
":068002012136A1\n"
":06800201213A01\n"
":06800201213CFF\n"
":06800201213D01\n"
":06800201213D3F\n"
":06800201213D40")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.