// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m):06..0201213(5[C-F]|[6-9A-C].|D[0-3]).").unwrap();
let string = ":06800201212E39
:06800201212E40
:06800201212EA5
:06800201212F00
:06800201212FFF
:06800201213000
:068002012134FF
:06800201213500
:0680020121359F
:068002012135A1
:068002012135BF
:068002012135C0
:068002012136A1
:06800201213A01
:06800201213CFF
:06800201213D01
:06800201213D3F
:06800201213D40";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}