re = /^P(\\d+Y)?(\\d+M)?(\\d+D)?(T(\\d+H)?(\\d+M)?(\\d+S)?)?$/
str = 'THIS IS FOR VALIDATING IS0 8601 DURATION STRINGS IN TERRAFORM'
# Print the match result
str.match(re) do |match|
puts match.to_s
end