package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^P(\\d+Y)?(\\d+M)?(\\d+D)?(T(\\d+H)?(\\d+M)?(\\d+S)?)?$`)
var str = `THIS IS FOR VALIDATING IS0 8601 DURATION STRINGS IN TERRAFORM`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}