$re = '`^P(\\\\d+Y)?(\\\\d+M)?(\\\\d+D)?(T(\\\\d+H)?(\\\\d+M)?(\\\\d+S)?)?$`';
$str = 'THIS IS FOR VALIDATING IS0 8601 DURATION STRINGS IN TERRAFORM';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);