re = /(?<=Clone of )[^.]*/i
str = 'Clone of Iteration1 - Web app
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result