const regex = /(?<=Clone of )[^.]*/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Clone of )[^.]*', 'gi')
const str = `Clone of Iteration1 - Web app
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);