import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(seção: (?'secao'\\d+), aptos: (?'aptos'\\d+)\\)";
final String string = "(seção: 509, aptos: 121)\n"
+ "(seção: 517, aptos: 118)\n"
+ "(seção: 327, aptos: 89), (seção: 328, aptos: 90)\n"
+ "(seção: 371, aptos: 89), (seção: 520, aptos: 53)\n"
+ "(seção: 331, aptos: 111), (seção: 332, aptos: 111), (seção: 334, aptos: 111)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}