using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(seção: (?'secao'\d+), aptos: (?'aptos'\d+)\)";
string input = @"(seção: 509, aptos: 121)
(seção: 517, aptos: 118)
(seção: 327, aptos: 89), (seção: 328, aptos: 90)
(seção: 371, aptos: 89), (seção: 520, aptos: 53)
(seção: 331, aptos: 111), (seção: 332, aptos: 111), (seção: 334, aptos: 111)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}