re = /\(\d{3}\)(-| )\d{3}(-|\s)\d{4}/m
str = '(514)-381-6273
(514) 284-3145
(514) 231-1341'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end