$re = '/\(\d{3}\)(-| )\d{3}(-|\s)\d{4}/m';
$str = '(514)-381-6273
(514) 284-3145
(514) 231-1341';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);