using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\d{3}\)(-| )\d{3}(-|\s)\d{4}";
string input = @"(514)-381-6273
(514) 284-3145
(514) 231-1341";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}