re = /(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?!.*[\!\@\#\$\%\^\&\*\(\)\[\]\{\}\`\~\|\\\/\?\>\<\.\,\:\;\'\"]).{1,20}/
str = 'a0A'
# Print the match result
str.match(re) do |match|
puts match.to_s
end