$re = '/(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?!.*[\!\@\#\$\%\^\&\*\(\)\[\]\{\}\`\~\|\\\\\/\?\>\<\.\,\:\;\'\"]).{1,20}/';
$str = 'a0A';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);