using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?!.*[\!\@\#\$\%\^\&\*\(\)\[\]\{\}\`\~\|\\\/\?\>\<\.\,\:\;\'\""]).{1,20}";
string input = @"a0A";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}