const regex = /\bperformance_data>scratch_tapes=\K\d*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bperformance_data>scratch_tapes=\\K\\d*', '')
const str = ` <performance_data>scratch_tapes=6; total_tapes=38;</performance_data>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}