use strict;
my $str = '7491260006';
my $regex = qr/^0([1-9]{2})([1-9]{2})([2-3]{1})([0-9]{3})([0-9]{4})$|([1-9]{2})([8-9]{1})([0-9]{3})([0-9]{4})$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";