# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^0([1-9]{2})([1-9]{2})([2-3]{1})([0-9]{3})([0-9]{4})$|([1-9]{2})([8-9]{1})([0-9]{3})([0-9]{4})$//;t' <<< "7491260006"